SOLVED - package configuration

Jun 28, 2013 at 8:09 AM
Edited Jul 3, 2013 at 9:47 AM
I am currently facing an issue while launching the application. The problem in my case is that hadoop streaming requires the complete path to the executable otherwise it does not work, it crashes saying that the file could not be found.
-mapper mapper.exe
does not work
-mapper " C:\....\mapper.exe"
works (note: I also need an additional space at the beginning otherwise hadoop removes the absolute path and uses only the filename, I know it seems dumb but without the space it does not work)
Where can I configure the package/visual studio to pass the full path to hadoop like shown in the example?
thanks a lot!
Jul 4, 2013 at 10:38 AM
I tried to run manually the application, but there are still some issues. I got rid of "-files" and put the absolute path directly in the "-mapper" argument.
Anyway while executing an error pops out asserting that MSFT_HADOOP_MAPPER_DLL is not set even if when i launced the program I explicitly initalized it
-cmdenv MSFT_HADOOP_MAPPER_DLL=C:/Users/.../hadoopTest00/MRLib/hadoopTest00.exe
Has anybody experienced a similar problem?